分类 极客笔记 下的文章

用Photoshop制作牛仔裤口袋装Ipod效果

先来看一下最终效果图哈~

1

第一步,先建立一个用来制作图标文件的文档以及一个仿制牛仔裤纹理的填充图案的小文档。

2

3

第二步:在5X5px的那个文档里用1px的铅笔画出斜线,然后做成透明的填充图案。(基础步骤不会的回去打屁股)

4

第三步:在图标文档中定义背景的颜色基调。用为牛仔裤有很多种颜色,就算是蓝色,也有深蓝色、水洗、以及类似Coolfire做的那种蓝绿色。

5

第四步:在背景层上新建空白层,用刚才定义的斜线填充文档。当然,因为原来的斜线是黑色的,所以这里你需要使用图层改一下这里的颜色,颜色没有什么要求,只要比背景淡一些就好。

6

第五步:牛仔裤肯定不是如此光滑的,所以我们要给背景添加基础的效果,我们首先给“背景”特曾添加杂色滤镜。如果觉得不够的话,再加一组蒙尘与划痕。

7

8

第六步:背景处理好之后,我们要处理现在看起来还不是很真实的斜线纹理,给“背景纹路”图层添加一组胶片颗粒滤镜,设置么,你如果要牛仔裤是粗面的,设置就调高点,要牛仔路是那种细面的,就调低一点。但是过低或者过高的设置会让效果看上去不好。

9

然后你就可以看到这样的效果了,感觉还可以(但是比我上次还原Coolfire效果时的要强烈了一点,所以两次效果做出来不太一样),接着我们新建一个名为“遮罩”的黑色图层,填充为0%

10

然后给这个层添加图层样式,压黑四个角,营造一下气氛。

11

第七步:好了,背景部分处理好了,我们开始图标部分。首先使用圆角矩形工具拉出一个形状——也就是牛仔裤的口袋,图标的主体。

12

填充调为0%后,开始设置图层样式。里面具体的颜色值,大家吸一下就知道了。也可以自由发挥。

13

14

15

16

17

第八步:口袋的底面弄出来后,复制一层为“口袋面”,然后用钢笔工具什么的调整一下形状,构建起口袋的整体感觉。

18

第九步:开始画牛仔裤特有的缝线。说实话,PS里面虚线真不方便,我调整了双重画笔好多次,画出来的虚线都不完美(后面会提到)。先设置一下笔刷吧,尺寸调到2px。其他如图:

19

然后形状工具中调成路径模式,拉出一个略小于口袋边框的形状。然后设置一下前景色,黄灰色即可,后面可以再调整。

20

21

然后描边路径,面板中选择画笔。就可以看到虚线的效果。但是这里我要想PS高人请教了,我这样描边路径,总是得不到完美的虚线,总是有一个或者两个边还是近乎实现的效果。我这里只能用笨方法删除实现,复制虚线,旋转调整一下得到现在的效果。

22

照葫芦画瓢把其他线做出来

23

然后是中间的横线,画一条路径即可描边了。

24

25

最后新建一层,用同样颜色的铅笔画出线头交接的地方,不用太细致,细致了反而不是牛仔裤粗矿的风格了。

26

第十步:到现在为止,整个口袋还是黑漆漆的一片。我们要把背景的纹理添加上去。复制开始制作的那个“背景纹理”图层,拖到“口袋面”图层之上,“线”图层之前。然后获得“口袋底”图层的选区,然后缩小2px的选区。

27

蒙板一下,得到只涵盖口袋底范围的纹理。改变一下混合模式为“滤色”,效果有差就好。

28

这是或觉得先啊、口袋边都过暗了,我们就简单调整一下颜色即可。

29

第十一步:开始往口袋里面放东西。其实就很简单了在网上找一个Ipod的矢量图(你也可以放其他更出彩的。。。我想找杜蕾斯,没找到),缩放到适合的大小和角度,如图。

30

获取“口袋面”图层的选区,反向模板一下这个Ipod,初步的Ipod插口效果就完成了。

31

32

光是插入,没有什么感觉。我们要模拟一下3D的凹凸感觉,所以接下来我们复制“口袋面”图层,栅格化。我们要用这个栅格化的图层做加深处理。

33

使用加深工具,大小50px什么的,曝光度调小一点。反向Ipod的选区(不然我们只能刷到Ipod的区域),我们需要通过加深Ipod的边缘,让各位观众感觉这个Ipod是真的插入了,而且是一插到底。

34

喂,简单刷几次够了啊,多了就过了。

35

第十二步:黄金12宫终于打到了双鱼座了,雅典娜我们来了。。。效果基本完成了,但是这条牛仔裤卖不出去吧?我们需要山寨一个——过程就不说了,这个再不会就无语了。

36

唔~~还要注意一下细节,给Ipod和口袋之前的部位加上柔和的阴影。

37

最后打上一个说明,完工!

38

0

Banner设计经验图文实例总结

欢迎交流以下是我总结的一些拙见,有什么不对的地方还请大家指出来,一起交流.本文只适合新手文字排版,高手就不必看了

1.将说明文字加个黑色背景层,突出文字的显示,并降低背景层的透明度

图中文字 “将爱 ” 书法字体设计

“情进行到底” 纤细字体设计 表现了女性的柔美,象征了爱情

文字放置在纯色背景之上,“将”和“底”连接了图中左右的人物

使人物之间产生关联,暗示了2人之间的爱情

clip_image002

2.将文字放置在开阔的背景之上,加点阴影,前景(文字)亮,背景暗 突出了文字主题

本例中运用了 文字的渐变叠加 文字的倾斜变形

左上角文字“天下“ 用一个小牌子突出

clip_image004

3.由于直接应用文字到背景图片上会有凌乱的视觉感,本图采用了一个不规则的黑色图形做文字背景,增加了一些神秘感和故事感

字体设计中突出了拯救,应用了渐变叠加效果

clip_image006

4.此图中说明性的小文字用黑色字体,文字放置的地方,背景都没有很多细节,让文字更加醒目,不会使文字和背景冲突

大文字(电视剧名称)运用了书法字体错位摆放,并黑色描边,加以背景色中的黄色,使文字与整幅图融合,让整幅图统一

“宫廷大剧”是图中的副标题,黑色,用黄色的不规则印章图形做背景,增加了几分古代感

clip_image007

5,图中中心文字放置在空调之上,使大家忽略了柜式空调,同时有凌乱感

那这个图做案例,因为 文字设计的有亮点

空调节和启动,重新设计字体,让字体有机械感,很符合此图的主题

文字设计时运用了叠加冰凉的图案,使用文字也瞬间冰霜了很多,给人凉爽清新的感觉

投影也增加了文字的质感

clip_image008

6.本图用有个性化的人物和高山顶合成而成

标题文字用了方正黄草,放大并图案填充,填充了熊熊烈火的图案,象征了战火。

并增加了黑色的投影

说明性的文字用白色,字体柔和,与画面的刚强对比,增加了画面的跳跃性

文字形状与背景中的大山相似,连绵起伏

背景用了红色并降低透明度,使文字更加醒目,也与画面中的红色想呼应

clip_image009

7.图中文字运用了标签式的设计,垂直构图

左上角文字运用了白色的梯形标签做背景

右下角文字则运用了红色的圆形标签做背景

文字和标签同时使用,可以让文字成为亮点,增加了画面的层次

有种画龙点睛的优势

clip_image010

8.本图中运用了文字作为背景

说明性文字还是运用了标签式,并围绕鞋子为中心环绕,产生了运转的动感

clip_image011

0

浅谈各个行业标识设计的好坏优劣标准

1、标识是否传达策略目标“对谁”“传达什么”“如何传达”“传达之后什么感受”
2、标识是否考虑到“用怎么样的形式与色彩传达”最初的设计目标……
3、标识是否考虑到“让谁产生印象? 并且是的什么样的视觉印象”……

 

当你接到这个标识任务时,事先要先做哪些准备?


当你接到这个标识任务时,中心一定要有将来的目标,设计目标就如同“我们公司要变成这样,因此要这么表现”一样,必须将企业理念跟传达理念等文字叙述转为具体的”用什么样的形式和色彩跟文字传达”

1

教你一些验证标志设计的好坏的方法。


有设计目的,自然就有对应的设计方法,而怎么检验此次设计的准确性呢?平时我是这么做的……

2

是否为先进的设计?关键字:先进性、未来性……


3

是前所未有、顶尖的、未知的、融通未来感、数字感和高科技感,具体可以采用透光纤维、金属色、塑料感等人工美的形式,这些和“自然感”、“人性”形成对比这种形式通常用于科技类企业、互联网、等创新性产业的标志。

是否为耳目一新的设计?关键字:新奇性、崭新性……


4

人们会对熟悉并且美好的东西产生亲密感和安心感,亲近性在绝大部分企业聘品牌化战略中不是最重要的,但是对于快速消费品行业、零售业、食品业则是首当重要的!

 

是否为有信赖感的设计?关键字:信赖感……


5

这类形象一般会使用金融机构、政府单位、医院行业、学校等等,给人感觉踏实,信赖的感觉,这种图形一般都是以方形、圆形为多,三角形,不规则形用得较少……

 

是否围为质朴体贴的设计?关键字:人性……


6

简单一点就是既有个性有独特,别无类似,当然了撞车也会经常碰到,但是个人认为如果你的创意很偶然的在世界的另一个地方找到了一个相同的,只要创意于该企业的理念策略一直,也无所谓……哈哈~~

 

是否让人看的懂?关键字:传播性


7设计标识一定要考虑传播的问题,一个标识让人看了2-3次感觉是这个样子,如果看10次以上觉得”原来如此“,那他的传达性就足够了……

 

是否让人能不失新鲜感?关键字:耐久性……


咋一看很质朴,没什么感觉,单纯的色彩,简单的图形,只需看好感就会出现,这样的设计我们称之为“耐久性”设计,这种设计一般像浪涛、陈幼坚设计公司这写作品较多……

 

是否容易开展VI设计?关键字:连续性……


8

能否在名片上、信封上、车体上展开应用,并且做的有效、有具有生气,或者是采用辅助图形的变化方法使设计能梳理的展开。


当然了,以上只是个人观点,现实设计案例中还有好多因素干扰设计师,其实也没办法,国内的整体设计环境就是这样,很多时候为了“商业目的”,不得不跟客户“妥协”,希望以上文章能对你有用即可,别无他求。

0

xhtml+css 复杂的视觉效果解决方案与技巧

今天呢,带来一篇在工作过程中遇到的比较麻烦的一个设计稿,也是我们公司产品模板里的一个,我会在下文中写出我在编写代码的过程中的思路

与变化,还有一些技巧的使用。已经将案例传上来了,大家可以下载细看。

首先我想说一下我之前写的第一篇技巧文章(CSS日常公用样式与一些解决方案)里的清除浮动的样式,那个我还是没有考虑周全,如下:

.clear { dipslay: block!important; float: none!important; clear: both; overflow: hidden; width: auto!important; height: 0!important; margin: 0 auto!important; padding: 0!important; font-size: 0; line-height: 0; }

改变过后的是

clear { dipslay: block!important; float: none!important; clear: both; overflow: hidden; width: auto!important; height: 0; margin: 0 auto!important; padding: 0!important; font-size: 0; line-height: 0; }

变化不大是吧?但是我想说的是你在用到这个样式清除浮动的时候,那个浮动的子类盒模型,他们的高度肯定不是固定的,那么我在这个.clear 样式里写的height: 0!important; 高度为0 声明为重要,也就没什么用了,因为浮动的子类盒模型的高是活的,所以不必为高度声明为重要,那如果浮动的子类盒模型的高度是死的,那就不需要清除浮动了,所以我后来把.clear 中height: 0 后面的声明为重要给删掉了。

第二一个就是我在文中提及的第二个问题jquery 扩展的lightbox 效果,在body中写 overflow: auto; height: 100%; 就可以解决掉了在ie6中内容高度不够,无法撑开整个body而让遮罩只遮到一半内容,不用写的像原来那样麻烦,是我把问题想复杂了。

还有就是在第二篇文章(XHTML+CSS解决方案 第一弹 IE6那些不得不说的恶心事 之 PNG透明背景的几种解决方案)里,png图片透明的方法,说的第四种方法在实际应用中在ie6里还会有问题出现,如果将png图片做为链接的话,并且已 经上传至服务器,那么你在访问的时候会发现你找不到你的png图片,必须要把鼠标移到链接上面才会出现,并且如果不是链接的话,那抱歉,你要刷新一下页面才会出现。

所以如果有哪位用了我说的那种办法,我在这里说声抱歉,当时没有测试完整,就放到了网上,给大家带来的不便,请见谅。

这个网站是前两天看书上写到的用htc文件+js 解决ie6 png透明的方法,比较好用,但不要用太小的图片用来平铺,这样会使你的ie6浏览器进入假死状态或是反应很慢,还有就是如果用css文件加载htc文件的时候要注意htc文件的路径问题!

下面开始说正文,我先把设计的效果图放出来,并且将图分离做为伪3D视图,看一下每个效果的层位置,再说一下,每个样式的方法和属性我不能一一解释,只能说一些大概的解决方法,要不这篇幅就太大了。整个网站的制作页面,我已经传了上来,大家可以下载后细看。

clip_image001

下面是伪3D分离视图(做的不好请见谅):

clip_image002

效果图中的背景图片我是在网上找到的一个jquery 扩展应用,把不需要的代码去掉后,就用做可适应浏览器的效果了。

那么知道效果图的层位置之后,我们要想,怎么将效果图中的三个层置于内容区的层位置以下,使用绝对定位后,并将层位置写成负值就可以了,但是这样写ie6会兼容吗,写过测试性的文档,如下:

* { margin: 0; padding: 0; }

html { overflow: hidden; width: 100%; height: 100%; }

body { overflow: auto; height: 100%; }

#main-bg { position: absolute; top: 0; left: 0; z-index: -3; width: 100%; height: 100%; }

#main-bg img { position: absolute; top: 0; left: 0; z-index: -3; }

clip_image003

虽然这样写了 火狐谷歌等现代浏览器可以实现

但是ie6不兼容怎么办?

那我们能不能换一个思路?(这个思路我也是想了有一会)

既然要内容要能滚动并与背景的三个区同在,而不干扰,还要兼容ie6,那他们就肯定是兄弟级关系,就是在同一盒模型里。

在写的时候要想,怎么能让内容区在内容填满后,还能自动向下滚动,那我们能不能按照body的特性,写一个假的body呢?按照 body的特性那就必须高度是先占满浏览器,或是能随着内容的多与少自动出现滚动条与消失,那么就要有overflow: auto与height: 100% 这两个样式了。

那么,下面这个是第二个测试性文档:

* { margin: 0; padding: 0; }

html, body { overflow: hidden; width: 100%; height: 100%; }

#main-bg { position: absolute; top: 0; left: 0; z-index: -3; width: 100%; height: 100%; }

#main-bg img { position: absolute; top: 0; left: 0; z-index: -3; }

#simulation-body { overflow: auto; height: 100%; }

clip_image004

将代码写成这样后

发现在ie6下内容区在内容超出了浏览器尺寸后右侧也出现滚动条了

说明我们测试成功了

那么下面我们就按效果图里的样子把我们要实现的效果再写出来!

70%透明黑的效果我用ie的滤镜透明效果与现代浏览器支持的透明效果一起用,就可以了。

写完后,整体代码如下:

* { margin: 0; padding: 0; }

html, body { overflow: hidden; width: 100%; height: 100%; }

#main-bg, #main-bg img, #main-repeat-line, #main-mask { position: absolute; top: 0; left: 0; width: 100%; height: 100%; }

#main-bg, #main-bg img { z-index: -3; }

#main-repeat-line { z-index: -2; background: url('../images/main_repeat_bg.gif') repeat; }

#main-mask { z-index: -1; background: #000; filter: alpha(opacity=60); opacity: 0.6; }

#simulation-body { position: relative; overflow: auto; height: 100%; }

而#simulation-body 中的 position: relative 的意图在于,当内容区内出现相对定位或是绝对定位的元素时,这些元素在ie6和7浏览器下就会变为假性固定定位,那么这不是我们想要的效果,所以就要加上 position: relative,以解决这个问题。让内容区在向下或是向上滚动时,相对定位与绝对定位的元素也会跟着上下移动。

clip_image005

好了,我们已经把想要得到的效果做出来了。那么我们现在要将首页的样式写出来,因为首页的内容要求是垂直居中显示,那么我们写的# simulation-body 在这里就用不到了,我们要重新写一个样式来定义。

定义之前,我们要先得到这个区域的高度等数值。得到数值后,我们就要写垂直居中的样式了,既然要垂直居中,那么肯定要用到绝对定位,百分比位置,负值外填充。如下:

#default-box { position: absolute; top: 50%; left: 0; width: 100%; height: 230px; margin: -115px 0 0; border-bottom: 1px solid #4c3e04; background: url('../images/default_nav_bg.png') repeat-x left bottom; text-align: center; }

由于我想要让这个样式下的子类尽量以行内元素来定义,所以我写了text-align: center,宽度是100% 是因为导航区域的透明背景色是随浏览器的宽度走的,所以要写100%,在这里说一下,块元素的宽度是随它的父级元素的宽度走的,所以在一些已经标明具体宽 度的父级元素内,子级元素的宽度就不要再次声明了,除非子级元素是浮动型的,ie里可以写具体宽度来清除浮动,当然也有别的办法。而绝对定位与固定定位的 宽度是要声明一下,否则你在浏览器里是看不到它们的。

然后将logo的样式写出来。如下:

#default-box #logo { display: inline; }

为了让#logo 只在 #default-box 下为行内元素,所以我把它写成了#default-box 的子类,不与二级页的#logo起冲突。因为该设计稿是模板类网站,logo会经常替换,所以在logo的样式上并没有写多少限制类的样式。

下面开始导航区了,导航那里的内容是左右居中的,用绝对定位左右居中就可以。但是后面的透明背景色怎么办?我们可以用ie的滤镜透明效果与现代浏览器支持的透明效果一起用,然后绝对定位,这样就可以放在导航的后面了,并且可以节省一张图片,如下:

#default-box .blank { position: absolute; bottom: 0; left: 0; display: block; width: 100%; height: 78px; background: #000; filter: alpha(opacity=60); opacity: 0.6; }

#default-box div { position: absolute; bottom: 0; left: 50%; width: 930px; margin: 0 0 0 -490px; line-height: 78px; text-transform: uppercase; }

#default-box div 这里为什么要用到div 而不用样式名,因为这个div层里已经不需要再写div了,所以我就没再命名。那么大体已经写了。下面开始写导航,因为要考虑到首页与二级页(在下面会放出)用的导航都一样,那我们就要再另起一行写样式了,不用做为谁的子类出现了。二级页面效果图如下:

clip_image006

导航样式如下:

ul#main-nav { position: relative; float: left; margin: 0 0 0 -10px; }

ul#main-nav li { display: inline; padding: 0 88px 0 0; }

ul#main-nav a { padding: 0 0 0 10px; font-weight: bold; font-size: 14px; }

ul#main-nav a:hover, ul#main-nav a.current { background: url('../images/main_nav_li.gif') no-repeat left center; color: #fc0; }

ul#main-nav 里的 margin: 0 0 0 -10px 是因为在当前页面或是鼠标触发后,在链接前面会出现一个小箭头,设计稿里箭头的宽度加上它与链接的间距是10像素,所以我向外负10像素,刚好可以在默认 显示的时候是与logo对齐的。还有人会问,为什么 a 标签要写在 ul 后面,而不是li的后面,我在这里说一下,在css样式表,一些固定的层嵌套关系即使你不按照html文档里那样写结构也不会说有什么语法错误,然后他们都是在一同父级元素内,所以ul#main-nav li a 里面的 li 是可以不写的,这样我们也可以减少一定的代码量,除非是在有样式冲突或是继承关系有特别要求的时候,才有必要写的特别明确的嵌套关系。

语言切换那里我们可以在公用样式部分里写.fr { display: inline; float: right; } 然后再回来写上语言切换的样式名称,如下:

.language {  }

.language a {  }

这样是为了以后修改方便,所以留些空,如果不需要那完全可以删掉。

最后就是页脚的问题了,由于在页脚在首页的位置是固定的,而在二级和三级页内是可滚动的,所以我们要写两个样式,可是我想用同一个样式名写,怎么办?那我们可以用不同的选择器来解决一下,代码如下:

#footer { width: 930px; margin: 90px auto 20px; }

#footer { font-size: 10px; }

p#footer { position: absolute; bottom: 20px; left: 50%; margin: 0 0 0 -490px; }

我在这里先定义了二级页的页脚样式,然后再用p#footer来指定只有用p选择器才能让#footer是绝对定位的,并且要把冲突的样式在p#footer里去掉,这样我们就写好了。

首页和二级页的大局样式已经写的差不多了,我把html文档贴上来给大家看一下

clip_image007

到二级页后

我们需要写一个放内容的盒模型,由于他的样式与上面已经写好的#footer是一样的,所以我们就可以把他们放到一起,如下:

#footer, #content { width: 930px; margin: 90px auto 20px; }

大的布局在这里已经写完了

往下就是一些内容区的内容增加了

下面开始写二级页了,那我们把首页复制一份或是另存为,得到一个二级页,然后将里面的

clip_image008

这些内容全部去掉 换上之前已经写好的,并且在里面写好大的布局样式

clip_image009

由于我们前面还没有写 #header 那我们要从前面的 #default中得到相同的样式,并且把冲突的样式去掉,还要让结构不变,代码如下:

#default-box div, #header div { position: absolute; bottom: 0; left: 50%; width: 930px; margin: 0 0 0 -490px; line-height: 78px; text-transform: uppercase; }

#header { position: relative; height: 53px; margin: 76px auto 0; padding: 28px 0 0; border-bottom: 1px solid #4c3e04; }

#header #logo { position: absolute; top: 0; left: 50%; margin: 0 0 0 -465px; }

#header div { position: static; margin: 0 auto; line-height: 54px; }

由于#header div和#default div中的一样样式是一样的,所以要让他们先读取一样的样式,然后再写出来与#default div 不一样的地方,这样就解决掉了问题

html文档如下:

clip_image010

与首页的区别就是换了一个id 而已,那这样给以后的修改带来的方便,大家可想而知。

第一个二级页是简历,那我们只要写一个样式,给文字一个行高就可以了。至于里面的文字段落在设计稿里是什么样。我们完全不必管,因为这样又浪费时间,最后还要让程序全部删掉。得到代码如下:

.about-wrap { line-height: 21px; }

html文档如下:

clip_image011

这样写的好处就是,减少嵌套关系,不必这么写:

clip_image012

而我们之前已经写了#content是对整体内容区的定位。那具体里面的东西该怎么写,就由像是about-wrap这类的父级样式来定义,如下:

.about-wrap p {  }

.about-wrap ul {  }

大概就说这么多吧,写的比较啰嗦,表达能力不太好,大家凑合看。

以后如果遇到更复杂的视觉设计稿,自己的思路与一些实际的应用技巧还会分享给大家的!

0

在众多的浏览器中难找归宿

LLq

自从QQ跟360大战后,就开始选择一款适合自己的浏览器。然后下载了几款较知名的浏览器安装待选!3Q大战那会,QQ那丫的不然用360浏览器的用户访问QQ空间。无奈!~虽然很支持360出的软件!

用过一段时间的Opera,确实,Opera的速度真的很快!不过,他的插件太少,而且大多都是E文的!可能国内使用Opera的人还太少吧!~

之后,以为在WordPress插件中,很多都是E文的,然后便使用了谷歌浏览器,它里面集成了一个网页自动翻译功能,很强大。嗯、翻译这块。我一直都是很支持谷歌的,翻译较为准确!

可是我用浏览器不单单只是为了要翻译网页中的E文呀!~在网上看博文的时候,人家总结了各个浏览器的优缺点~综合分析了下,觉得还是火狐浏览器适合我用。。刚刚上手不久,有点不习惯~不过,还是挺喜欢火狐的,插件功能超多、

0

网页设计中关于组成元素的命名规范

clip_image001
网站设计及基本框架结构:

1.    Container:就是将页面中的所有元素包在一起的部分。

这部分还可以命名为: “wrapper“, “wrap“, “page“

2.    Header:是网站页面的头部区域,一般来讲,它包含网站的logo和一些其他元素。

这部分还可以命名为:“page-header” (或 pageHeader)

3.    Navbar:等同于横向的导航栏,是最典型的网页元素。

这部分还可以命名为:“nav”, “navigation”, “nav-wrapper”

4.    Menu:区域包含一般的链接和菜单。

这部分还可以命名为: “subNav “, “links“,“sidebar-main”

5.   Main:是网站的主要区域,如果是博客的话它将包含的日志。

这部分还可以命名为: “content“, “main-content” (或“mainContent”)

6.   Sidebar:部分可以包含网站的次要内容,比如最近更新内容列表、关于网站的介绍或广告元素等…

这部分还可以命名为: “subNav “, “side-panel“, “secondary-content“

7.    Footer:包含网站的一些附加信息。

这部分还可以命名为: “copyright“

需要注意的几点:

1.尽量考虑为元素命名其本身的作用或”用意”,达到语义化。不要使用表面形式的命名.如:red/left/big等

2.组合命名规则:
[元素类型]-[元素作用/内容]
如:搜索按钮: btn-search
登录表单:form-login
新闻列表:list-news

3.涉及到交互行为的元素命名:
凡涉及交互行为的元素通常会有正常、悬停、点击和已浏览等不同样式,命名可参考以下规则:
鼠标悬停::hover   点击:click   已浏览:visited
如:搜索按钮: btn-search、btn-search-hover、btn-search-visited

Photoshop图层结构规范:

Photoshop图层命名遵循树形结构,凡某元素组成的图层大于3层,即可形成组,所有图层尽量避免使用默认命名(图层+编号)。

第一级图层结构如下图:

clip_image002

第二级结构图例(医院网站):

clip_image003

第三级结构图例及效果图对比(医院新闻栏目):

clip_image004
效果图

clip_image005
图层命名结构

 

附表:常用命名汇总

1、页头:header

2、登录条:loginbar

3、标志:logo

4、侧栏:sidebar

5、广告条:banner

6、导航:nav

7、子导航:subNav

8、菜单:menu

9、子菜单:subMenu

10、下拉菜单:dropMenu

11、工具条: toolbar

12、表单:form

13、栏目:column

14、箭头:arrow

15、搜索:search

16、搜索按钮:btn-search

17、滚动条:scroll

18、内容:content

19、标签页:tab

20、文章列表:list

21、提示信息:msg

22、小技巧:tips

23、栏目标题:title

24、链接:links

页25、脚:footer

26、服务:service

27、热点:hot

28、新闻:news

29、下载:download

30、注册:regsiter

31、状态:status

32、按钮:btn

33、投票:vote

34、合作伙伴:partner

35、版权:copyright

36、网站地图: sitemap
0

通过CSS Sprites技术优化网页加载速度

通常,我们在设计网页的时候都会用到许许多多的图片来美化网页。然后,过多的图片除了会减慢网页的加载速度,还会加重服务器的负担。打一个很简单的比例,当我们想要将一个文件夹内的文件拷过去其他盘符的时候,会移动很久,但是如果我们将文件夹打包成一个文件,传输速度会快很多。这是因为在传输的时候减少对磁盘的读取次数!

 

好的,回到我们正题上、我们在设计网页的时候,会用到许许多多的图片文件。我们可以用【CSS Sprites】将图片整合成一个图片集,在网页加载的时候,只需从服务器中请求读取这个图片集,然后利用CSS Sprites处理这个图片集,将他们分部到特定的位置!

 

CSS Sprites

那么,如何通过CSS实现这个功能呢?

1、将小图片整合到一张大的图片上。

2、根据具体图片(或图标)在打图上的位置,给背景定位。

3、在需要用到某个小图片的时候,在CSS里面加入“background-position:-*px-8px”.

 

例外需要注意的是:

1、在图片排列上面:颜色相近的图片放在一起,可以减少输入的色数,可以尽量缩小文件的大小。

2、合并图片生成时候:PNG8的图像比GIF图片要小30%,所以,在生成图片的时候尽量使用PNG文件格式。

3、利用第三方然见对生成的图片进行二次压缩,比如使用FireWorks生成的PNG图片比Photoshop生成的图片更小。而用一些专业的压缩软件可以让图片再小一些!。。精益求精嘛~呵呵~

 

好的。能说的就这么多,希望这片短短的技术问能给大家一些启示~~

0

大学VB期末考试试题及答案

相关资源:
ASP.Net程序设计课程2010期末考试试题(一)
ASP.Net程序设计课程2010期末考试试题(二)
ASP.Net程序设计课程2010期末考试试题(三)

 

VB期末考试试题 A

一、 填空题

1、VB程序设计的主要特点是 (1)可视化设计 (2)事件驱动编程

2、在VB中,最主要的两种对象是 (3)窗体(form (4)控件
3、工程是构成应用程序文件的 (5)集合

4、方法是VB提供的一种 (6)特殊子程序 ,用来完成一定的操作。

5、浮点类型数据包括单精度型和___(7)双精度__数据。

6、事件是窗体或控件对象识别的___(8)_动作___。

7、可用窗体的___(9)Print _ 方法在窗体中显示文字。

8、 复选框控件Value属性指示复选框处于____(10)选中___或禁止状态(暗淡的)中的某一种。

9、在VB中,修改窗体的 (11)高度(Height) (12)宽度(Width) 属性值,可改变窗体的大小。

10、双击工具箱中的控件图标,可在窗体的 (13)中央 出现一个尺寸为缺省值的控件。

11、在MsgBox函数中,如果缺省title参数,则使用 (14)工程1 作为消息框的标题。

12、设x=34.58,语句Print Format(x,“000.0”)的输出结果是 (15)34.6

13、在VB 中,数值型变量的初值为 (16)0 ,Varant型变量的初值为 (17) ,布尔型变量的初值为 (18)False

14、设置窗体的 (19)Picture 属性,可在窗体上显示图片。

15、程序运行工程中,清除MP图片框中的图片应使用语句 (20)Cls

二、选择题

1、菜单控件只包括一个事件,即 (1)C ,当用鼠标单击或键盘选中后按“回车”键时触发该事件,除分隔条以外的所有菜单控件都能识别该事件。

A、GotFocus B、Load C、Click D、KeyDown

2、滚动条控件(如图所示)的Max属性所设置的是 (2) A

clip_image002

A、滚动框处于最右位置时,一个滚动条位置的Value属性最大设置值

B、 单击滚动条和滚动箭头之间的区域时,滚动条中滚动块的最大移动量

C、单击滚动条的箭头区域时,滚动条中滚动块的最大移动量

D、滚动条控件无该属性

3、SQL 语句 Select * Form student 中的 *表示 (3) B

A、所有记录 B、所有字段 C、所有表 D、都不对

4、以下选项中,不属于标签的属性是 (4)C

A、Enabled B、Caption C、Default D、Font

5、要求改命令按钮显示的文本,应当在属性窗口中改变的属性是 (5) A

A、Caption B、Name C、Text D、Label

6、设置一个单选按钮(OptionButton)所代表选项的选中状态,应当在属性窗口中改变的属性是 (6)D

A、Caption B、Name C、Text D、Value

7、允许在菜单项的左边设置打勾标记,下面哪种论述是正确的? (7)D

A、在标题项中输入&,然后打勾 B、在索引项中打勾

C、在有效项中打勾 D、在复选项中打勾

8、当执行以下过程时,在窗体上将显示 (8) A

Private Sub Command1_Click( )

Print “VB”;

Print “Hello! “;

Print “VB”

End Sub

A、 VBHello!VB B、 VB

Hello!VB

C、 VB D、 VB

Hello! VB Hello!

VB

9、语句Print “The answer is:”;20/4-2的结果为 (9)B

A、The answer is 20/4-2 B、The answer is 3

C、The answer is “20/4-2” D、非法语句

10、下列哪个控件是容器控件 (10)B

A、Image B、Picture C、ComboBox D、FileListBox

11、若要将窗体从内存中卸载出去,其实现的方法是 (11)D

A.Show B.Hide C.Load D.UnLoad

12、以下选项中,不是 Visual Basic控件的是 (12) A

A.窗体 B.定时器 C.单选框 D.命令按钮

13、双击窗体中的对象后,Visual Basic将显示的窗口是 (13) A

A.代码窗口 B.工具箱 C.项目(工程)窗口 D.属性窗口

14、可决定窗体的左上角是否有控制菜单的属性是 (14)A

A.ControlBox B.MinButton

C.MaxButton D.BorderStyle

15、设有如下语句:

Strl=InputBox(”输人”,””,”练习”)

从键盘上输人字符 “示例”后,Strl的值是 (15)D

A.“输入” B.“ ” C.“练习” D.“示例”

16、窗体Form1的Name属性是Frm1,它的单击事件过程名是 (16)C
A. Form1_Click B.Form_Click C. Frm1_Click D. Me_Click
17、窗体的hide属性的含义是 (17)A
A.隐藏 B.展现 C.装入 D.卸载

18、若要设置定时器控件的定时时间,需设置的属性是 (18)C

A.Enabled B.Value C.Interval D.Text

19、能够改变复选框中背景颜色的属性是 (19) C

A.Value B.FontColor C.BackColor D.Font

20、窗体能响应的事件是 (20)B

A.ActiveForm B.Load C.Drive D.Change

三、判断题(判断下列正确与否,正确的打√,错误的打ⅹ。)

1、三种方式的组合框都允许用户输入哪些不在列表框中的选项。(Х)

2、图象框中的Stretch属性为true时,其作用是图形自动调整大小以适应图象控件。(Х)

3、在菜单编辑器中使用“索引”时,可有一组菜单项具有相同的“名字”。(Х)

4、通过改变属性窗口中的Name属性,来改变窗体的标题。()

5、创建VB应用程序的三个主要步骤是:(1)创建应用程序界面(2)设置控件(3)编写代码。(Х)

6、变量是指在程序运行过程中其值可以改变的那些量,而值不能改变的是常量。()

7、已知P=MsgBox(“Howareyou?”,VbYesNo+VbQuestion,“Hello!”),变量P是Integer数据类型。()

8、工程文件的扩展名是 .vbg 。()

9、VB允许设计和使用用户自己设计的控件。()

10、OptionButton控件没有DblCliek事件。(Х)

11、同一条记录中的各数据具有相同的类型。()

12、使用Data控件可以直接显示数据库中的数据。(Х)

13、ImageList 是一个图像容器控件,可用作工具栏的图像库。()

14、当用户单击工具栏按钮时,将触发工具栏按钮的ButtonClick事件。()

15、在VB的工程资源管理器中,如果从工程中移除已经保存过的文件,该文件仍然被物理删除(真正删除)。(Х)

16、如果列表框的ListConut的属性为10,则列表框最后一项的ListIndex值为10。(Х)

17、要是某个命令按钮不起作用,应将该按钮的Enabeld属性设置为False。()

18、使用数组定义语句:Dim D$(10),则数组D中各元素的值为空。(Х)

19、如果在一行中输入多条语句,各语句之间用使用 ;分隔。(Х)

20、在代码窗口中输入某行代码并按回车键之后,如果代码变成红色,说明该行代码有语法错误。 ()

四、读程序题,写出程序运行结果

1、 Private Sub Form_Click()

Static SUM As Integer

I = 1

Do While I<=10

SUM = SUM + I

I = I + 1

Loop

Print SUM

End Sub

运行程序,第一次单击窗体: 5 5

第二次单击窗体: 1 1 0

2、 Private Sub Form_Click()

Print “*”; Tab(6); 2, Tab(15); 5

Print

For I = 15 To 16

Print I;

For j = 2 To 6 Step 3

Print Tab(3 * j); j * I;

Next j

Print

Next I

End Sub

程序运行结果:

VB程序设计与应用》参考答案

 

一、填空题 1 2 3 4 5
答案 可视化设计 事件驱动编程 窗体(form 控件 集合
题号 6 7 8 9 10
答案 特殊子程序 双精度 动作 Print 选中
题号 11 12 13 14 15
答案 高度(Height) 宽度(Width) 中央 工程1 34.6
题号 16 17 18 19 20
答案 0 False Picture Cls
二、选择题 1 2 3 4 5
答案 C A B C A
题号 6 7 8 9 10
答案 D D A B B
题号 11 12 13 14 15
答案 D A A A D
题号 16 17 18 19 20
答案 C A C C B
三、判断题 1 2 3 4 5 6 7 8 9 10
答案 Х Х Х Х Х
11 12 13 14 15 16 17 18 19 20
答案 Х Х Х Х Х

四、程序阅读题:

(一) (10分)

1 、 55

2、 110

(二)、 (10分)

* 2 5

15 30 75

16 32 80

0

一个小型企业网局域网网络工程建设案例

案例介绍

本案例主要介绍鞋厂局域网网络工程建设。其交换机采用2台港湾的uHammer24E,负责内部局域网的信息交换以及与接入路由器通讯,广域网接入采用港湾 NetHammer M141路由器作为网络中心,负责与Internetr接入,并在上面实现DHCP功能,实现地址自动分配。是一个小型企业网局域网网络工程建设案例。

学习目标

完成本案例的学习后,您应该能够:

(1) 掌握快速以太网技术

(2) 掌握Vlan的划分及其实现

(3) 掌握Internet广域网接入

(4) 掌握ACL访问控制

(5) DHCP功能实现


目 录

一、网络建设需求:… 5

二、网络设备选型及配置说明… 5

三、实施准备… 6

1、项目人员组织结构及分工… 6

2、工程时间安排、工程进度安排… 6

3、IP地址的划分,VLAN的分配… 7

4、现场检查与到货验收… 8

四、实施… 9

一)、网络中心和各楼交换机联合调试… 9

二)、Internet接入的调试:… 11

三)、各交换机配置文件和IOS的备份… 14

五、测试… 15

系统测试原理与方法… 15

硬件设备测试与验收… 15

系统集成测试… 15

一、网络建设需求:

某鞋厂新建网络:

1、鞋厂新建网络分为两部分:办公区与生产车间。

2、办公区有30台主机,办公区要求能上Internet。

3、生产车间区差不多10台主机,生产车间的主机不能上Internet。

二、网络设备选型及配置说明

根据以上网络建设需求,我们可以看出此网络用户主机不多,应用较简单,建议在网络中心配置一台智能二层交换机uHammer24E作为核心层交换机,它提供了24个百兆以太网电口,再配一台uHammer24E与其级联。按照功能,划分为办公区与生产车间两个VLAN

在Internet接入上,目前在Internet接入的ISP是采用电信的10M接入,建议配一台NetHammer M141路由器,做访问Internet NAT地址转换功能。

设备清单

序号

产品

描述

数量

备注

1

接入交换机–μHammer24E以太网交换机

 

1.1

μHammer24E

增强型以太网交换机,24*10/100M,2个HC扩展插槽,220V交流

2

 

2

Internet接入路由器

 

2.1

NetHammer M141

1个10/100Base-TX 以太网口,1个备份口,1个配置口,3个WIC扩展插槽,模块化接入路由器

1

 

3

网络设备机柜

4.1

网络设备机柜

42U标准网络设备机柜

1

 
         
 


三、实施准备

1、项目人员组织结构及分工

² 项目经理:

工作内容及范围:负责项目的总体协调

² 商务负责:

工作内容及范围:负责与商务相关的工作

² 技术负责:

工作内容及范围:负责项目的总体规划与实施协调

² 工程技术人员:

工作内容及范围:负责项目的具实施

2、工程时间安排、工程进度安排

预计4月中下旬设备全部到货,总预计1周时间完成工程。

具体安排如下:

根据项目各子任务的工作量估算以及我们对网络工程的经验,制定项目实施进度计划表格。

表1:项目实施进度计划 ☆

工程安排

合同签定—7.19

7.20

7.21

7.22—7.26

7.28

设备订购

         

设备到货验收

         

系统安装工程

         

现场培训

         

系统整体测试

         

系统验收测试

         

3、IP地址的划分,VLAN的分配

配合计算机网络中心整理虚网分配,将相同职能部门划分为同一虚网.并制成表格。

1)鞋厂网络包括2个部分:

² 办公区

² 生产车间

两上个部分VLAN要做到各自独立划分,IP子网互不重叠。

2)IP用户分配静态IP地址或从DHCP服务器动态获得IP

本方案办公区服务器及关键主机采用静态分配IP地址,其他主机采用动态分配IP地址;生产车间采用动态分配IP地址。

3)VLAN的划分原则:

从将来的发展考虑,要预留足够的扩展空间。为VLAN预留足够的扩展空间,也可以方便网络的优化。

VLAN 10 分配给办公;

VLAN 20 分配给生产车间。

具体实现如下表:

VLAN、IP分配表:功能单位

IP地址范围

VLAN IP地址

应用预留

VLAN ID

VLAN名称

办公区

192.168.1.0/24

192.168.1.254

 

VLAN 10

office

生产车间

192.168.2.0/24

192.168.2.254

 

VLAN 52

V52

4、现场检查与到货验收

检验到的硬件设备的货号及数量是否与设备订货清单一致。

检验到货的设备是否完好无损。

验收的结果应该提供一份由参与验收的用户和系统集成商签名的硬件验收清单,并注明日期。

如果没有可见的设备损害,那么在验货后,即开始设备的安装和调试。

设备到货,进行设备验收,记录设备的序列号,表格如下:

Item No.

Name of Goods

(产品名称)

Main Specification

(产品性能)

Quantity(数量)

S/N NO.

(序列号)

1-1

NetHammer M141

NetHammer M141

1个10/100Base-TX 以太网口,1个备份口,1个配置口,3个WIC扩展插槽,模块化接入路由器

1

1-2

uHammer24E

 

μHammer24E

增强型以太网交换机,24*10/100M,2个HC扩展插槽,220V交流

2

 


四、实施

一)、网络中心和各楼交换机联合调试

1、拓扑示意图:

clip_image002

2、交换机uHammer24E(Cisco2950-24)的调试

A、第一台uHammer24E交换机

调试PC通过串口配置线连接第一台交换机uHammer24E

uHammer24E交换机上电,启动进入配置模式

命名该交换机:

hostname uHammer24E_1

设置ENABLE密码:

Enable password harbour

² 创建VLAN信息

全局配置模式下:

以下是思科交换机配置命令:

Vtp mode server

Vtp domain harbour

Vlan 10 /*创建办公楼的vlan,其名称为bangong,其ID号为 10*/

Name bangong

Exit

Vlan 20

Name workroom

Exit

Int range fa0/1-20

Switch port mode access

Switchport access vlan 10

Int fa0/25

Switchport mode trunk

Switchport trunk allow vlan all

interface vlan bangong 10 /*创建办公楼的vlan,其名称为bangong,其ID号为 10*/

add port 1/25 tagged /* 把端口1/25以打标记的方式加入到bangong Vlan中*/

add port 1/1-20 untagged /* 把端口1/1以不打标记的方式加入到bangong Vlan中,此一般为直接接PC终端的端口*/

exit

interface vlan workroom 20

add port 1/25 tagged

add port 1/21-24 untagged

exit

² 删除vlan

如果对所输入的VLAN信息不满意的话,可以先删除vlan,然后再创建vlan:

删除一个vlan

思科:no vlan 10

港湾:No int vlan vlan-name

再再创建vlan

Int vlan vlan-name vlanID

B第二台uHammer24E(Cisco 2950)交换机

调试PC通过串口配置线连接第二台交换机uHammer24E

uHammer24E交换机上电,启动进入配置模式

命名该交换机:

hostname uHammer24E_2

设置ENABLE密码:

Enable password harbour

² 创建VLAN信息

全局配置模式下:

思科交换机配置命令:

Vtp mode client /*为户端,VLan信息会从服务器端学习到。*/

Vtp domain harbour

Int range fa0/1-16

Switch port mode access

Switchport access vlan 10

Exit

Int range fa0/17-24

Switch port mode access

Switchport access vlan 20

Exit

Int fa0/25

Switchport mode trunk

Switchport trunk allow vlan all

Exit

interface vlan bangong 10 /*创建办公楼的vlan,其名称为bangong,其ID号为 10*/

add port 1/25 tagged /* 把端口1/25以打标记的方式加入到bangong Vlan中*/

add port 1/1-16 untagged /* 把端口1/1以不打标记的方式加入到bangong Vlan中,此一般为直接接PC终端的端口*/

exit

interface vlan workroom 20

add port 1/25 tagged

add port 1/17-24 untagged

exit

² 删除vlan

如果对所输入的VLAN信息不满意的话,可以先删除vlan,然后再创建vlan:

删除一个vlan

思科:No vlan VLanID

港湾:No int vlan vlan-name

再再创建vlan

思科:No vlan VLanID

港湾:Int vlan vlan-name vlanID

二)、Internet接入的调试:

clip_image004

拓扑图说明

鞋厂申请电信10M光纤宽带接入,分配一个的合法的INTERNET IP地址以供路由器使用。光纤宽带转成五类网线,接入路由器eth0/1接口上。

M141路由器上有两个以太口,其中1个接口接Ineternet,另外一个接内网,它承担着两个Vlan路由――即单臂路由功能,同时也承担着与外网Internet接入的路由及NAT功能,具体表达如下:

² 单臂路由实现

(思科与港湾配置命令相同。)

interface eth0/0

no ip address

ip nat inside

!

interface eth0/0.1

encapsulation dot1q 10

ip address 192.168.1.254 255.255.255.0

!

interface eth0/0.2

encapsulation dot1q 20

ip address 192.168.2.254 255.255.255.0

!

² DHCP功能实现

在办公区中,除部分主机用静态指定IP地址,其空间为192.168.1.1-100,其余部分用动态分配IP,其空间为192.168.1.101-200。因此必须在路由器上实现DHCP功能,其实现方法如下:

1、思科路由器配置:

ip dhcp pool pool1

network 192.168.1.0 255.255.255.0

default-router 192.168.1.254

dns-server 202.101.107.55 202.101.98.55

ip dhcp excluded-address 192.169.1.1 192.168.1.100

ip dhcp excluded-address 192.169.1.201 192.168.1.254

2、港湾路由器配置:

dhcp subnet 192.168.1.0 mask 255.255.255.0

arp-update

range 192.168.1.101 192.168.1.200

default-lease-time 32000

option routers 192.168.1.254

option domain-name-servers 202.101.107.55 202.101.98.55

² 外网接口配置

interface eth0/1

ip address 222.77.69.210/30

ip nat outside

² NAT功能实现

A.配置上网网段的ACL,只有办公区网段能实现上网。

access-list 1 permit 192.168.1.0 0.0.0.255

B.在内、外网口上启用NAT

interface eth0/0

ip nat inside

interface eth0/1

ip nat outside

!

C.全局模式下启用NAT功能

Ip nat on(思科默认是启用的,不用这条命令)

ip nat inside source list 1 interface ethernet0/1

² 接入Internet静态路由配置

ip route 0.0.0.0 0.0.0.0 222.77.69.209

三)、各交换机配置文件和IOS的备份

设备配置文件和IOS映像文件的备份

载超级终端方式下,配置主机运行TFTP服务器,配置主机通过网络线连接交换机,运行命令:

copy startup-config tftp:// 命令备份交换机上的配置文件

copy flash tftp://命令备份交换机上的IOS映像文件。


五、测试

系统测试原理与方法

从实施阶段可分成:

² 单个系统或相对独立部件的测试,例如交换机的自检等等;

² 子系统的测试,例如中心网络的测试等等;

² 整个网络系统的测试。

测试的目标是为了保证用户能够科学而公正地验收供应商提供的设备和软件,系统集成商提供的整套系统,也是为了保证供应商和系统集成商能够准确无误地提供合同所要求的设备和系统。所以,测试的目的对用户而言是为了验收。

硬件设备测试与验收

² 部件级测试

部件级测试指对设备中各个部件的功能、可靠性、耐用性和可维性的测试,升档能力的衡量等。该类测试一般已在原厂的生产过程中完成,用户只需在使用过程中加以观测即可。

² 设备级测试

设备级测试主要包括对设备的处理能力、可靠性、可扩充性、开放性等方面进行测试。设备级测试需用有关的测试工具、仪器或软件来进行,也可在实际应用中对其某些性能加以测试。

² 系统级测试

系统级测试主要包括网络的连通性测试,系统的可靠性测试,系统的响应时间,系统的抗干扰测试,系统的安全保密性测试等。这一类测试可借助于某些网络测试工具或网络管理和测试软件来完成。

系统集成测试

² 功能性测试:

测试系统应提供的每一个功能和安全性限制,检查系统是否已正常实现所有功能。

² 连通性测试:

测试网络上任意站点间是否能够相互传输数据,测试各个终端能否登录中心服务器,并访问数据库,对数据库进行正常的操作;

² 稳定性测试:

在不间断运行的一段时间内,系统有无异常现象发生,如有异常,是由系统自动处理还是系统管理员人工干预处理,不间断的测试时间以一周(7天)为限;

² 重载测试:

在系统处于重载工作状况时,通过计算机系统的监控软件,以及网络系统的管理软件监测计算机系统和网络系统的性能指标;

0

教你如何申请一个整个互联网通用的Gravatar头像

Gravatar(个人全球统一标识)是globally recognized avatar(直译为”全球标识的头像”)的缩写。它可以在一切支持Gravatar的场合显示你的专属头像,就是能让你在发布评论的时候可以使用专属头像,它将和你填写的email地址一一对应,wordpress2.5以上版本,已经集成了Gravatar头像功能。具体申请步骤如下:
◆登陆http://en.gravatar.com/site/signup,填写注册邮箱之后,点击”Signup”按钮;

◆到注册的邮箱中查收邮件并点击其中的链接确认;

◆在弹出页面中填写相关内容;

◆点击页面中部框框下的链接”Add one by clicking here!”;
clip_image001
◆如果要从自己的本地硬盘上传一张头像,那就点击第一个链接”My computer’s hard drive”上传头像;
clip_image002
◆进入Crop页面,滑动滑块选择你需要的照片区域后点击页面下部的”CROP”按钮;

◆给自己的头像评定级别。G 普通级、PG 辅导级、R 和 X 为限制级,一般不黄不暴力的选G就行了;
clip_image003
◆点击页面中的头像照片,在弹出的小页面里点击”Confirm”钮确认;

◆到支持Gravatar头像功能的网站,输入申请头像时的邮箱发表评论试试吧,要想改头像的话只需要到http://en.gravatar.com/网站里登陆后修改即可。

0